aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2024-02-26 14:44:30 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2024-02-27 12:39:00 +0000
commitfef1539e33d3f7cd84e888df8c736d6b6f749203 (patch)
tree481debdba7db9267758a22da4a9688c591f820df
parent185cdd84e1ce9a5ddf3f7dcc4bffecd7268c308b (diff)
qtbase: add PACKAGECONFIG for wayland support
Qtbase now has configuration test for enabling wayland support. It needs to be enabled for QtWayland to work. Add new PACKAGECONFIG option to make sure it's enabled when DISTRO_FEATURES has wayland. Pick-to: 6.7 Task-number: QTBUG-117386 Change-Id: If5d88eb3de5422e19bf61919fceda37b05d705c1 Reviewed-by: Alex Bu <alex.bu@qt.io>
-rw-r--r--recipes-qt/qt6/qtbase_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index ea44ba9..b7b0405 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -51,6 +51,7 @@ PACKAGECONFIG ?= "\
PACKAGECONFIG_GRAPHICS ?= "\
${@bb.utils.filter('DISTRO_FEATURES', 'vulkan', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', \
bb.utils.contains('DISTRO_FEATURES', 'x11', 'gl', 'kms gbm gles2 eglfs', d), 'no-opengl linuxfb', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
@@ -136,6 +137,7 @@ PACKAGECONFIG[no-opengl] = "-DINPUT_opengl=no"
PACKAGECONFIG[png] = "-DFEATURE_system_png=ON,-DFEATURE_png=OFF,libpng"
PACKAGECONFIG[tslib] = "-DFEATURE_tslib=ON,-DFEATURE_tslib=OFF,tslib"
PACKAGECONFIG[vulkan] = "-DFEATURE_vulkan=ON,-DFEATURE_vulkan=OFF,vulkan-headers,vulkan-loader"
+PACKAGECONFIG[wayland] = "-DFEATURE_wayland=ON,-DFEATURE_wayland=OFF,wayland wayland-native"
PACKAGECONFIG[xcb] = "-DFEATURE_xcb=ON,-DFEATURE_xcb=OFF,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil xcb-util-cursor"
PACKAGECONFIG[xkbcommon] = "-DFEATURE_xkbcommon=ON,-DFEATURE_xkbcommon=OFF,libxkbcommon,xkeyboard-config"