aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2022-11-14 12:45:02 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2022-11-16 13:41:22 +0200
commit54bf4ded71360713df446dfc59241f7e0d13d2e0 (patch)
tree33a275071035363536b1ba9ebee5cf09b7c24b92 /recipes-qt
parent42326e359f17b150c67430dbb89230c9f12c6d9c (diff)
webengine: adapt to WE 6.3 -> 6.4 update
Picked & squashed together from meta-qt6(6.4) the relevant parts from commits "65972077eb19bac169cab82dfd6aa29e5c56c691 qtwebengine: move to 98-based chromium" and "dc6a7797e0235c59adf48271b4c3101192be7e13 Add QtPDF" ...leaving the QtPDF addition part & obsolete chromium branch adjustments out. Change-Id: Ied9d5dc31af336dcc85207d2075d8b06f6650d53 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt6/chromium-gn.inc4
-rw-r--r--recipes-qt/qt6/qtwebengine/chromium/0001-v8-qemu-wrapper.patch36
-rw-r--r--recipes-qt/qt6/qtwebengine_git.bb2
3 files changed, 21 insertions, 21 deletions
diff --git a/recipes-qt/qt6/chromium-gn.inc b/recipes-qt/qt6/chromium-gn.inc
index 1b0e023..5d697ab 100644
--- a/recipes-qt/qt6/chromium-gn.inc
+++ b/recipes-qt/qt6/chromium-gn.inc
@@ -56,7 +56,7 @@ python do_create_v8_qemu_wrapper () {
d.expand('${STAGING_DIR_HOST}${base_libdir}')]
qemu_cmd = qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST', True),
qemu_libdirs)
- wrapper_path = d.expand('${B}/src/core/Release/${TARGET_ARCH}')
+ wrapper_path = d.expand('${B}')
bb.utils.mkdirhier(wrapper_path)
wrapper_path = os.path.join(wrapper_path, "v8-qemu-wrapper.sh")
with open(wrapper_path, 'w') as wrapper_file:
@@ -77,7 +77,7 @@ python do_create_v8_qemu_wrapper () {
# to build. Instead of using QEMU, change the wrapper to try to run the
# tools directly, using the target dynloader.
python do_create_v8_qemu_wrapper:x86-64 () {
- wrapper_path = d.expand('${B}/src/core/Release/${TARGET_ARCH}')
+ wrapper_path = d.expand('${B}')
bb.utils.mkdirhier(wrapper_path)
wrapper_path = os.path.join(wrapper_path, "v8-qemu-wrapper.sh")
with open(wrapper_path, 'w') as wrapper_file:
diff --git a/recipes-qt/qt6/qtwebengine/chromium/0001-v8-qemu-wrapper.patch b/recipes-qt/qt6/qtwebengine/chromium/0001-v8-qemu-wrapper.patch
index 8bd1313..83a9e29 100644
--- a/recipes-qt/qt6/qtwebengine/chromium/0001-v8-qemu-wrapper.patch
+++ b/recipes-qt/qt6/qtwebengine/chromium/0001-v8-qemu-wrapper.patch
@@ -1,4 +1,4 @@
-From 87769922a455bec09951f95e8cd3402cf646ee33 Mon Sep 17 00:00:00 2001
+From 23d02fd87c766b6aef2a5aa81186b3db3f13b82a Mon Sep 17 00:00:00 2001
From: Raphael Kubo da Costa <raphael.kubo.da.costa@intel.com>
Date: Tue, 7 Nov 2017 15:24:32 +0100
Subject: [PATCH] v8: qemu wrapper
@@ -16,50 +16,50 @@ Signed-off-by: Maksim Sisov <msisov@igalia.com>
2 files changed, 5 insertions(+)
diff --git a/chromium/tools/v8_context_snapshot/BUILD.gn b/chromium/tools/v8_context_snapshot/BUILD.gn
-index 6e86a543558..eee89b37064 100644
+index d868696dbf2..298273818ef 100644
--- a/chromium/tools/v8_context_snapshot/BUILD.gn
+++ b/chromium/tools/v8_context_snapshot/BUILD.gn
-@@ -56,6 +56,7 @@ if (use_v8_context_snapshot) {
- output_path = rebase_path(output_file, root_build_dir)
+@@ -72,6 +72,7 @@ if (use_v8_context_snapshot) {
+ output_path = rebase_path(output_file, root_build_dir)
- args = [
-+ "./v8-qemu-wrapper.sh",
- "./" + rebase_path(
- get_label_info(
- ":v8_context_snapshot_generator($v8_snapshot_toolchain)",
+ args = [
++ "../../../../v8-qemu-wrapper.sh",
+ "./" + rebase_path(get_label_info(":v8_context_snapshot_generator",
+ "root_out_dir") +
+ "/v8_context_snapshot_generator",
diff --git a/chromium/v8/BUILD.gn b/chromium/v8/BUILD.gn
-index db762c8c300..11e96d1ea3b 100644
+index 2f99c3d70b0..9b28cf2ed4c 100644
--- a/chromium/v8/BUILD.gn
+++ b/chromium/v8/BUILD.gn
-@@ -1521,6 +1521,7 @@ template("run_torque") {
+@@ -1870,6 +1870,7 @@ template("run_torque") {
}
args = [
-+ "./v8-qemu-wrapper.sh",
++ "../../../../v8-qemu-wrapper.sh",
"./" + rebase_path(
get_label_info(":torque($toolchain)", "root_out_dir") + "/torque",
root_build_dir),
-@@ -1637,6 +1638,7 @@ action("generate_bytecode_builtins_list") {
+@@ -2002,6 +2003,7 @@ action("generate_bytecode_builtins_list") {
outputs = [ "$target_gen_dir/builtins-generated/bytecodes-builtins-list.h" ]
deps = [ ":bytecode_builtins_list_generator($v8_generator_toolchain)" ]
args = [
-+ "./v8-qemu-wrapper.sh",
++ "../../../../v8-qemu-wrapper.sh",
"./" + rebase_path(
get_label_info(
":bytecode_builtins_list_generator($v8_generator_toolchain)",
-@@ -1682,6 +1684,7 @@ template("run_mksnapshot") {
+@@ -2047,6 +2049,7 @@ template("run_mksnapshot") {
data = []
args = [
-+ "./v8-qemu-wrapper.sh",
++ "../../../../v8-qemu-wrapper.sh",
"./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
"root_out_dir") + "/mksnapshot",
root_build_dir),
-@@ -5133,6 +5136,7 @@ if (v8_enable_i18n_support) {
+@@ -5849,6 +5852,7 @@ if (v8_enable_i18n_support) {
outputs = [ output_file ]
args = [
-+ "./v8-qemu-wrapper.sh",
++ "../../../../v8-qemu-wrapper.sh",
"./" + rebase_path(
get_label_info(
":gen-regexp-special-case($v8_generator_toolchain)",
diff --git a/recipes-qt/qt6/qtwebengine_git.bb b/recipes-qt/qt6/qtwebengine_git.bb
index bf4b4a9..c98cfa3 100644
--- a/recipes-qt/qt6/qtwebengine_git.bb
+++ b/recipes-qt/qt6/qtwebengine_git.bb
@@ -73,7 +73,7 @@ PACKAGECONFIG[snappy] = "-DFEATURE_webengine_system_snappy=ON,-DFEATURE_webengin
PACKAGECONFIG[spellchecker] = "-DFEATURE_webengine_spellchecker=ON,-DFEATURE_webengine_spellchecker=OFF"
PACKAGECONFIG[webchannel] = "-DFEATURE_webengine_webchannel=ON,-DFEATURE_webengine_webchannel=OFF,qtwebchannel"
PACKAGECONFIG[webrtc] = "-DFEATURE_webengine_webrtc=ON,-DFEATURE_webengine_webrtc=OFF,libvpx"
-PACKAGECONFIG[webrtc-pipewire] = "-DFEATURE_webengine_webrtc_pipewire=ON,-DFEATURE_webengine_webrtc_pipewire=OFF,pipewire glib-2.0"
+PACKAGECONFIG[webrtc-pipewire] = "-DFEATURE_webengine_webrtc_pipewire=ON,-DFEATURE_webengine_webrtc_pipewire=OFF,pipewire glib-2.0 libepoxy"
PACKAGECONFIG[zlib] = "-DFEATURE_webengine_system_zlib=ON -DFEATURE_webengine_system_minizip=ON,-DFEATURE_webengine_system_zlib=OFF -DFEATURE_webengine_system_minizip,zlib minizip"
FILES:${PN} += "\