aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2022-05-25 12:24:47 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2022-11-09 20:45:21 +0200
commitcf01e7bf3c1aaab59b0bd7c36087d2a7ae6b5a10 (patch)
treee916eaf380579468ecb6d763de7bc87150937b5c /recipes-qt
parent77b03a5a5329acc18e99288519227950823ab327 (diff)
Add zlib dependency for qtbase
Zlib is mandatory dependency, meaning if there is no system one qt will do bundled one. This is important to know which one is used as webengine will try to build also bundled one. Task-number: QTBUG-103149 Change-Id: Ie7cc83dea558a5605295133fb0bf6fe0a3217492 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit a565bccb0722fa3f76de4aa33c0f1d4cdc819a0b)
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt6/qtbase_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index fedc682..47e1f07 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -53,7 +53,7 @@ PACKAGECONFIG_FONTS ?= ""
PACKAGECONFIG_SYSTEM ?= ""
PACKAGECONFIG_DISTRO ?= ""
PACKAGECONFIG_DEFAULT ?= "accessibility dbus udev gui widgets icu openssl \
- jpeg png dbus libinput fontconfig harfbuzz \
+ jpeg png dbus libinput fontconfig harfbuzz zlib \
${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \
${@bb.utils.contains('BBFILE_COLLECTIONS', 'openembedded-layer', 'zstd', '', d)} \
"
@@ -77,6 +77,7 @@ PACKAGECONFIG[developer-build] = "-DFEATURE_developer_build=ON,-DFEATURE_develop
PACKAGECONFIG[cups] = "-DFEATURE_cups=ON,-DFEATURE_cups=OFF,cups"
PACKAGECONFIG[dbus] = "-DFEATURE_dbus=ON,-DFEATURE_dbus=OFF,dbus"
PACKAGECONFIG[udev] = "-DFEATURE_libudev=ON,-DFEATURE_libudev=OFF,udev"
+PACKAGECONFIG[zlib] = "-DFEATURE_system_zlib=ON,-DFEATURE_system_zlib=OFF,zlib"
PACKAGECONFIG[zstd] = "-DFEATURE_zstd=ON,-DFEATURE_zstd=OFF,zstd"
# corelib