aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo@setantas.net>2011-02-06 00:41:50 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:15:15 -0300
commit0a5cacdb9c25d79df02d7b201ab1f2277caceca3 (patch)
tree42b56d93f8a30bb4109f259b511ff7e6eaeadaff /CMakeLists.txt
parente8a7efe5905ab8a1b333e5634081b4afcff7c334 (diff)
The option "avoid protected hack" is now set via command line.sb-1.0.0-rc1
Instead of the old ugly way of compiling the behaviour forever using "#define". Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc7a706d6..23a0b41ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,6 @@ set(shiboken_MINOR_VERSION "0")
set(shiboken_MICRO_VERSION "0")
set(shiboken_VERSION "${shiboken_MAJOR_VERSION}.${shiboken_MINOR_VERSION}.${shiboken_MICRO_VERSION}")
-option(AVOID_PROTECTED_HACK "Avoid protected hack on generated bindings." FALSE)
option(BUILD_TESTS "Build tests." TRUE)
if(MSVC)
@@ -48,14 +47,6 @@ else()
set(PATH_SEP ":")
endif()
-if(WIN32 OR AVOID_PROTECTED_HACK)
- message(STATUS "Avoiding protected hack!")
- add_definitions("-DAVOID_PROTECTED_HACK")
- set(AVOID_PROTECTED_HACK ON)
-else()
- message(STATUS "Using protected hack!")
-endif()
-
# uninstall target
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake"
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"