aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2011-01-20 16:14:07 -0200
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:13:49 -0300
commit38e10e17700b5381022315729f531f2b863ee3ae (patch)
treebaf38f85aa573ab5359b49f08f7e9e86395d752c /CMakeLists.txt
parentd931b4cf3c4e9fd3bf3e4909f096625da69a78ee (diff)
Use SBK_PYTHON_INCLUDE_DIR instead of PYTHON_INCLUDE_DIRS or PYTHON_INCLUDE_PATH.
Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Lauro Moura <lauro.neto@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb4372ceb..f7087c187 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,6 +102,12 @@ if(APPLE)
set(SBK_PYTHON_LIBRARIES "-undefined dynamic_lookup")
endif()
+if(CMAKE_VERSION VERSION_LESS 2.8)
+ set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_PATH})
+else()
+ set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_DIRS})
+endif()
+
add_subdirectory(libshiboken)
add_subdirectory(doc)
@@ -117,12 +123,6 @@ else()
message(WARNING "Some dependencies were not found, shiboken generator compilation disabled!")
endif()
-if(CMAKE_VERSION VERSION_LESS 2.8)
- set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_PATH})
-else()
- set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_DIRS})
-endif()
-
add_subdirectory(data)
# dist target