aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-12-22 19:17:02 -0200
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:12:50 -0300
commit6b1c034faef6a78f7e0681f55203a0fd9774d12d (patch)
tree55c4164a5da792bc0e3b81a9ca0f4029ee4b65af /CMakeLists.txt
parent5b57a4085dc68640870373b00f3d7c8dd894a466 (diff)
Fix Py_DEBUG detection on Windows.
On Windows sysconfig.get('Py_DEBUG') can return None instead of 0. Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfacdb844..d0891ce99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ add_custom_target(uninstall "${CMAKE_COMMAND}"
# Detect if the python libs were compiled in debug mode
execute_process(
COMMAND ${PYTHON_EXECUTABLE} -c "from distutils import sysconfig; \\
- print sysconfig.get_config_var('Py_DEBUG')"
+ print bool(sysconfig.get_config_var('Py_DEBUG'))"
OUTPUT_VARIABLE PY_DEBUG
OUTPUT_STRIP_TRAILING_WHITESPACE)