aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-07-27 11:05:05 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2010-07-27 11:08:42 -0300
commit7bd306347b8d55343e783a340f8bdc723111944f (patch)
tree45e7153c55401f53bf4e0c42538e4937f7359d94 /CMakeLists.txt
parent1b4094837f983d6273a81daffc5bbffedc82cf2c (diff)
Fixed build to completely avoid debug symbols when compiling in release mode.
Reviewed by Luciano Wolf <luciano.wolf@openbossa.org> Reviewed by Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 21cd2de1e..4267eb208 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,7 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
set(SBK_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
else()
set(SBK_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})
+ add_definitions("-DNDEBUG")
endif()
if (BUILD_TESTS)