aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-10-25 18:25:50 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:08:51 -0300
commit8b34f0eee6d33c468bc71e08fe29990f835b1695 (patch)
treec0af281008a051401fb2397886bd919952e0f1e7 /CMakeLists.txt
parentd487546eb6d06e0016e890e81fbbf8907cf90b49 (diff)
libshiboken now sets debug flags for all modules linking against it.
The information was added to cmake and pkg-config files. Reviewed by Lauro Moura <lauro.neto@openbossa.org> Reviewed by Renato Araujo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc4c83487..a0a4469d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,6 +78,8 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
message(WARNING "Compiling shiboken with debug enabled, but the python executable was not compiled with debug support.")
else()
add_definitions("-DPy_DEBUG")
+ set(SBK_ADD_PY_DEBUG_DEFINITION "add_definitions(\"-DPy_DEBUG\")")
+ set(SBK_PKG_CONFIG_PY_DEBUG_DEFINITION " -DPy_DEBUG")
endif()
set(SBK_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
set(SHIBOKEN_BUILD_TYPE "Debug")
@@ -90,6 +92,7 @@ if(APPLE)
endif()
+
if (BUILD_TESTS)
enable_testing()
endif()