aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-11-19 18:47:41 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:08:59 -0300
commitd7e399febc75e708bbd34da48199291604f08659 (patch)
tree1a160487305efc9724235323c9ab9c03d6ea6b80 /CMakeLists.txt
parentf315a69eca35fd24b05a07237130ee861254615f (diff)
Fixes SHIBOKEN_PYTHON_INCLUDE_DIR variable for cmake versions lesser than 2.8.
Reviewed by Luciano Wolf <luciano.wolf@openbossa.org> Reviewed by Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fd6ff326..2f0546339 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,8 +91,6 @@ if(APPLE)
set(SBK_PYTHON_LIBRARIES "-undefined dynamic_lookup")
endif()
-
-
if (BUILD_TESTS)
enable_testing()
endif()
@@ -110,6 +108,12 @@ if (QT4_FOUND AND ApiExtractor_FOUND AND GeneratorRunner_FOUND AND PYTHONLIBS_FO
else()
message("!! Some dependencies were not found, shiboken generator compilation disabled!")
endif()
+
+if(CMAKE_VERSION VERSION_LESS 2.8)
+ set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_PATH})
+else()
+ set(SBK_PYTHON_INCLUDE_DIR ${PYTHON_INCLUDE_DIRS})
+endif()
add_subdirectory(data)
set(ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${shiboken_VERSION})