aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Ehresman <jpe@wingware.com>2012-12-11 15:44:59 -0500
committerHugo Parente Lima <hugo.lima@openbossa.org>2012-12-17 15:10:27 +0100
commit46fe1eac50b094a6252e7a6a678a438f1b2c8f9a (patch)
treeceaa712f446fd5cca8d86b189d70456142176e86 /libshiboken/CMakeLists.txt
parentfdf8e4b70e2a82cda581ceae06a1c98fb20114f0 (diff)
Optionally assert on free'd pointer with a valid wrapper.
Use a debug mode callback that's called every time free is called to detect wrappers that are still in the binding manager's map after the C++ object is deleted. When it's enabled 10+ of the PySide tests fail. Change-Id: I30a40d48f6c4560ff0a3755d61c26ea4c6dd2758 Reviewed-by: Hugo Parente Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index feb849898..c8575e737 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -26,6 +26,7 @@ set(libshiboken_SOVERSION "${libshiboken_MAJOR_VERSION}.${libshiboken_MINOR_VERS
set(libshiboken_SRC
basewrapper.cpp
+debugfreehook.cpp
gilstate.cpp
helper.cpp
sbkconverter.cpp