aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2011-12-09 19:00:11 -0200
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:18:26 -0300
commitcd110ab3f4f912e2f9e400909f2d3d90abbb9d60 (patch)
treeeca46f03cda305638ee154bba1bca81fbe26f49a /libshiboken/CMakeLists.txt
parent26e008d9b3135cdeedfb6cd2f36b3369d1fc7c71 (diff)
Implemented PSEP 0106.
Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Paulo Alcantra <pcacjr@gmail.com>
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index 7d8a7ded8..b57a814c9 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -7,6 +7,8 @@ else()
set(shiboken_SUFFIX "")
endif()
+configure_file(sbkversion.h.in sbkversion.h @ONLY)
+
#Find installed sparsehash
find_path(SPARSEHASH_INCLUDE_PATH sparseconfig.h PATH_SUFFIXES "/google/sparsehash")
if(SPARSEHASH_INCLUDE_PATH)
@@ -35,6 +37,7 @@ shibokenbuffer.cpp
)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
${SBK_PYTHON_INCLUDE_DIR}
${SPARSEHASH_INCLUDE_PATH})
add_library(libshiboken SHARED ${libshiboken_SRC})
@@ -62,6 +65,7 @@ install(FILES
typeresolver.h
shibokenbuffer.h
sbkpython.h
+ "${CMAKE_CURRENT_BINARY_DIR}/sbkversion.h"
DESTINATION include/shiboken${shiboken_SUFFIX})
install(TARGETS libshiboken EXPORT shiboken
LIBRARY DESTINATION "${LIB_INSTALL_DIR}"