aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2018-06-25 15:24:11 +0200
committerChristian Tismer <tismer@stackless.com>2018-06-26 07:39:34 +0000
commit4a32f9d00b043b7255b590b95e9b35e9de44c4ed (patch)
treeaa92fcc7b8f325c714b224995a3a2680ec9a5cec /setup.py
parent11c443016275093e4c713a3fbafdaea8967fca7c (diff)
Prepare Limited API for Python 3.7
PySide has successfully been tested with the Python 3.7 branch. There will be no change in the areas that are important for us. It is then safe to bump the supported version and the limited API version checks to fully include Python 3.7. The macro errors in the limited API was fixed by a pull request, but it was too late to get it into 3.7rc1. The error workaround was therefore extracted into pep384_issue33738.cpp and will be deactivated later. Change-Id: Iec3f277b02cac03a5cf44cbcf955ddc690c112e5 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 42d74ca7..9ab77af4 100644
--- a/setup.py
+++ b/setup.py
@@ -270,6 +270,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Database',
'Topic :: Software Development',
'Topic :: Software Development :: Code Generators',