aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSimo Fält <simo.falt@theqtcompany.com>2016-06-03 11:36:38 +0300
committerChristian Tismer <tismer@stackless.com>2016-06-03 09:17:23 +0000
commit6b8818ccdaba58fb1309be32d2263c14f3ea08b7 (patch)
tree3bc457ec955fe2ba14be7c76b6b654b5b0105d95 /setup.py
parentd4b4f07d1ae4a5b831c2a24d2a18916efaad2fd7 (diff)
Include Qt framework headers in osx
While using Qt binaries installed with Qt Company installer, pyside can't find header files which are installed to lib/Qt<module>.framework/Headers directory. Change-Id: If74f5b3bf0f139bbcc6e9b62fb16e125f6ca9d4c Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ddd801919..4be210bcb 100644
--- a/setup.py
+++ b/setup.py
@@ -633,7 +633,11 @@ class pyside_build(_build):
cmake_cmd.append("-DUSE_PYTHON_VERSION=3.4")
if sys.platform == 'darwin':
- cmake_cmd.append('-DALTERNATIVE_QT_INCLUDE_DIR=' + self.qtinfo.headers_dir)
+ # When using Qt from QtCompany installers, headers are under framework directories
+ if os.path.isdir(self.qtinfo.headers_dir + "/../lib/QtCore.framework"):
+ cmake_cmd.append('-DALTERNATIVE_QT_INCLUDE_DIR=' + self.qtinfo.headers_dir + "/../lib/")
+ else:
+ cmake_cmd.append('-DALTERNATIVE_QT_INCLUDE_DIR=' + self.qtinfo.headers_dir)
if OPTION_OSXARCH:
# also tell cmake which architecture to use