aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-15 14:15:16 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2018-01-31 07:39:55 +0000
commit5d458c258fbaf3b24ffa0132093be4d6af2f8dfd (patch)
treedd2ba904413810b704af5b122ee6c83f6e77d1ff /sources/pyside2/CMakeLists.txt
parentc3f7967ff3699be8d68e00f875d01f526061166d (diff)
Add Qt3D
Task-number: PYSIDE-487 Change-Id: I17100eda57fbe5015b6c8ff531a3c62b22e8de95 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/pyside2/CMakeLists.txt')
-rw-r--r--sources/pyside2/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/sources/pyside2/CMakeLists.txt b/sources/pyside2/CMakeLists.txt
index bfd8eb5be..8dc1816f0 100644
--- a/sources/pyside2/CMakeLists.txt
+++ b/sources/pyside2/CMakeLists.txt
@@ -290,6 +290,9 @@ if(WIN32)
list(APPEND ALL_OPTIONAL_MODULES AxContainer)
endif()
list(APPEND ALL_OPTIONAL_MODULES WebChannel WebEngineWidgets WebKit WebKitWidgets WebSockets)
+if (Qt5Core_VERSION VERSION_GREATER 5.9.3) # Depending on fixes in Qt3D
+ list(APPEND ALL_OPTIONAL_MODULES 3DCore 3DRender 3DInput 3DLogic 3DAnimation 3DExtras)
+endif()
# Modules to be built unless specified by -DMODULES on command line
if (NOT MODULES)