aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-09-04 12:46:32 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-09-04 12:55:02 +0000
commit7fa1f9316f1cd0b5fba3f59e9edd14be90db9fd4 (patch)
tree47fdbbd65fe77f92b3a8517202ad7da139cc7577 /sources/pyside2/PySide2/QtCore/CMakeLists.txt
parent10453490629859a01048d0b21688d6617279eeaf (diff)
Re-enable bindings for QUuid
Remove comments, add test. The claimed cyclic dependency apparently disappeared when porting to Clang. Task-number: PYSIDE-487 Change-Id: I44556fb5de92d83bd9471a41a03db9f6eeff0a31 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/pyside2/PySide2/QtCore/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtCore/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/sources/pyside2/PySide2/QtCore/CMakeLists.txt b/sources/pyside2/PySide2/QtCore/CMakeLists.txt
index 0439f0a5c..f685b61d7 100644
--- a/sources/pyside2/PySide2/QtCore/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtCore/CMakeLists.txt
@@ -10,9 +10,6 @@ else()
set(SPECIFIC_OS_FILES "")
endif()
-# TODO: Fix cycling dependency when generating QDataStream operator<< for QUuid
-set (QtCore_SRC_FIXED_ME ${QtCore_GEN_DIR}/quuid_wrapper.cpp)
-
set(QtCore_SRC
${QtCore_GEN_DIR}/qabstractanimation_wrapper.cpp
${QtCore_GEN_DIR}/qabstracteventdispatcher_timerinfo_wrapper.cpp
@@ -141,6 +138,7 @@ ${QtCore_GEN_DIR}/qtimezone_offsetdata_wrapper.cpp
${QtCore_GEN_DIR}/qtranslator_wrapper.cpp
${QtCore_GEN_DIR}/qurl_wrapper.cpp
${QtCore_GEN_DIR}/qurlquery_wrapper.cpp
+${QtCore_GEN_DIR}/quuid_wrapper.cpp
${QtCore_GEN_DIR}/qvariantanimation_wrapper.cpp
${QtCore_GEN_DIR}/qwaitcondition_wrapper.cpp
${QtCore_GEN_DIR}/qwritelocker_wrapper.cpp