aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt
diff options
context:
space:
mode:
authorOswald Buddenhagen <oswald.buddenhagen@qt.io>2017-05-22 16:44:51 +0200
committerOswald Buddenhagen <oswald.buddenhagen@qt.io>2017-05-22 18:22:49 +0200
commit427c7147d23fa21c6e8bd08407b1badc48b49c3c (patch)
treed2742c7ffdfa167bcf6e68f06ce7524bc441102d /sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt
parent4ec9cfa3c6b895c0cf50227c189cfa542de88b64 (diff)
move everying into sources/pyside2 (5.9 edition)
in preparation for a subtree merge. this should not be necessary to do in a separate commit, but git is a tad stupid about following history correctly without it.
Diffstat (limited to 'sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt b/sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt
new file mode 100644
index 000000000..c616e1234
--- /dev/null
+++ b/sources/pyside2/PySide2/QtTextToSpeech/CMakeLists.txt
@@ -0,0 +1,40 @@
+project(QtTextToSpeech)
+
+set(QtTextToSpeech_SRC
+${QtTextToSpeech_GEN_DIR}/qtexttospeech_wrapper.cpp
+${QtTextToSpeech_GEN_DIR}/qtexttospeechengine_wrapper.cpp
+${QtTextToSpeech_GEN_DIR}/qvoice_wrapper.cpp
+# module is always needed
+${QtTextToSpeech_GEN_DIR}/qttexttospeech_module_wrapper.cpp
+)
+
+make_path(QtTextToSpeech_typesystem_path
+ ${QtCore_SOURCE_DIR}
+ ${QtCore_BINARY_DIR}
+ ${QtTextToSpeech_SOURCE_DIR})
+
+set(QtTextToSpeech_include_dirs ${QtTextToSpeech_SOURCE_DIR}
+ ${QtTextToSpeech_BINARY_DIR}
+ ${Qt5Core_INCLUDE_DIRS}
+ ${Qt5TextToSpeech_INCLUDE_DIRS}
+ ${SHIBOKEN_INCLUDE_DIR}
+ ${libpyside_SOURCE_DIR}
+ ${SHIBOKEN_PYTHON_INCLUDE_DIR}
+ ${QtCore_GEN_DIR})
+
+set(QtTextToSpeech_libraries pyside2
+ ${SHIBOKEN_PYTHON_LIBRARIES}
+ ${SHIBOKEN_LIBRARY}
+ ${Qt5Multimedia_LIBRARIES}
+ ${Qt5TextToSpeech_LIBRARIES}
+ ${Qt5Core_LIBRARIES})
+
+set(QtTextToSpeech_deps QtCore QtMultimedia)
+
+create_pyside_module(QtTextToSpeech
+ QtTextToSpeech_include_dirs
+ QtTextToSpeech_libraries
+ QtTextToSpeech_deps
+ QtTextToSpeech_typesystem_path
+ QtTextToSpeech_SRC
+ "")