aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtXml/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-11-28 14:57:31 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-12-07 12:41:39 +0000
commit4d82ee992992251bcadf0097a4df60fe7c3b7ef8 (patch)
treee1289f18413679c2def060821980c93452cecf26 /sources/pyside2/PySide2/QtXml/CMakeLists.txt
parent69755075484b75f2e7b97663b9135be90be6140b (diff)
Make it hard to use the create_pyside_module function incorrectly
Rewrite the function to use keyword arguments instead of ordered arguments. Also add error detection when required arguments are not passed, or have a typo in them. Adjust all the module cmake files to use keyword arguments. Change-Id: I7bb0c6561d7dca1e7f673e29eb457da50ae5df04 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'sources/pyside2/PySide2/QtXml/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtXml/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/sources/pyside2/PySide2/QtXml/CMakeLists.txt b/sources/pyside2/PySide2/QtXml/CMakeLists.txt
index 9c724cffb..7a6a707b7 100644
--- a/sources/pyside2/PySide2/QtXml/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtXml/CMakeLists.txt
@@ -52,10 +52,9 @@ set(QtXml_libraries pyside2
${Qt5Xml_LIBRARIES})
set(QtXml_deps QtCore)
-create_pyside_module(QtXml
- QtXml_include_dirs
- QtXml_libraries
- QtXml_deps
- QtXml_SOURCE_DIR
- QtXml_SRC
- "")
+create_pyside_module(NAME QtXml
+ INCLUDE_DIRS QtXml_include_dirs
+ LIBRARIES QtXml_libraries
+ DEPS QtXml_deps
+ TYPESYSTEM_PATH QtXml_SOURCE_DIR
+ SOURCES QtXml_SRC)