aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2022-02-18 09:32:29 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2022-03-18 09:23:18 +0100
commitf81168387be7879f9167405b28d29ba26e7b3f14 (patch)
tree98b0bb11a86703c9621b0be2886d245fd232fa05 /sources/pyside6/PySide6/QtGui/CMakeLists.txt
parented6bb6cf8f8f6005309f038f16134d478f15a1f3 (diff)
Add a context manager for override cursors
[ChangeLog][PySide] A context manager for override cursors has been added. It is now possible to write code like: with QApplication.setOverrideCursor(Qt.WaitCursor):... Change-Id: I443ce82389b48656f21c98df17d97e1b3b3323b5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'sources/pyside6/PySide6/QtGui/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtGui/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/sources/pyside6/PySide6/QtGui/CMakeLists.txt b/sources/pyside6/PySide6/QtGui/CMakeLists.txt
index 5bdb38253..2c95c71af 100644
--- a/sources/pyside6/PySide6/QtGui/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtGui/CMakeLists.txt
@@ -189,6 +189,7 @@ ${QtGui_GEN_DIR}/qtexttable_wrapper.cpp
${QtGui_GEN_DIR}/qtexttablecell_wrapper.cpp
${QtGui_GEN_DIR}/qtexttablecellformat_wrapper.cpp
${QtGui_GEN_DIR}/qtexttableformat_wrapper.cpp
+${QtGui_GEN_DIR}/qtguihelper_qoverridecursorguard_wrapper.cpp
${QtGui_GEN_DIR}/qtoolbarchangeevent_wrapper.cpp
${QtGui_GEN_DIR}/qtouchevent_wrapper.cpp
${QtGui_GEN_DIR}/qtransform_wrapper.cpp
@@ -233,5 +234,7 @@ create_pyside_module(NAME QtGui
TYPESYSTEM_NAME ${QtGui_BINARY_DIR}/typesystem_gui.xml
DROPPED_ENTRIES QtGui_DROPPED_ENTRIES)
-install(FILES ${pyside6_SOURCE_DIR}/qpytextobject.h DESTINATION include/PySide6/QtGui/)
+install(FILES ${pyside6_SOURCE_DIR}/qpytextobject.h
+ ${pyside6_SOURCE_DIR}/qtguihelper.h
+ DESTINATION include/PySide6/QtGui/)