aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtHelp/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2024-03-25 13:28:43 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2024-04-04 13:44:07 +0200
commit5af78c7c420afebee05535130b059aa2809258b2 (patch)
tree6d1db4fd4f98df186cb97dfcd72f75a6374ac3fb /sources/pyside6/PySide6/QtHelp/CMakeLists.txt
parentf89113e21645b5076d47b656140f0ceecf35fa09 (diff)
Build system: Clean Qt libraries linked by the modules
Only the bound Qt library needs to be linked, it will bring its dependencies. Add explanatory comment for the exceptions (QtTest, QtSql). Pick-to: 6.7 Task-number: PYSIDE-2649 Change-Id: Ib84d37248578a76400d307bb5d050005110677c3 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io> Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/pyside6/PySide6/QtHelp/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtHelp/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/sources/pyside6/PySide6/QtHelp/CMakeLists.txt b/sources/pyside6/PySide6/QtHelp/CMakeLists.txt
index 88697dbab..85bda0c10 100644
--- a/sources/pyside6/PySide6/QtHelp/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtHelp/CMakeLists.txt
@@ -40,9 +40,6 @@ set(QtHelp_include_dirs ${QtHelp_SOURCE_DIR}
${QtCore_GEN_DIR}
)
set(QtHelp_libraries pyside6
- ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES}
${Qt${QT_MAJOR_VERSION}Help_LIBRARIES})
set(QtHelp_deps QtWidgets)