aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtLocation/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-06 22:57:42 +0200
committerCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-07 15:31:43 +0200
commit985ee0b6e55bc116f287ff2a09265fd3ef629f37 (patch)
tree6d7d17d964183064bd26c8fd9e629173eea063e0 /sources/pyside6/PySide6/QtLocation/CMakeLists.txt
parent9fcb650a3f86c208d02cd3102edcebdda9b9571a (diff)
cmake: update minimum Qt version for 6.0+ compat
Bumping modules compatibility, using 6.0.0 as the base since we the rename from PySide2 took place already, and this code is not supposed to be backward compatible. Pick-to: 6.0 Change-Id: I471b151ef50f5a5974561bf2e619017f7beb621a Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/pyside6/PySide6/QtLocation/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtLocation/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/sources/pyside6/PySide6/QtLocation/CMakeLists.txt b/sources/pyside6/PySide6/QtLocation/CMakeLists.txt
index 5489afae9..9e58d94ac 100644
--- a/sources/pyside6/PySide6/QtLocation/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtLocation/CMakeLists.txt
@@ -10,6 +10,7 @@ ${QtLocation_GEN_DIR}/qgeoroute_wrapper.cpp
${QtLocation_GEN_DIR}/qgeoroutereply_wrapper.cpp
${QtLocation_GEN_DIR}/qgeoroutesegment_wrapper.cpp
${QtLocation_GEN_DIR}/qgeoserviceprovider_wrapper.cpp
+${QtLocation_GEN_DIR}/qgeoserviceproviderfactoryv2_wrapper.cpp
${QtLocation_GEN_DIR}/qplace_wrapper.cpp
${QtLocation_GEN_DIR}/qplacecontentreply_wrapper.cpp
${QtLocation_GEN_DIR}/qplacedetailsreply_wrapper.cpp
@@ -47,11 +48,6 @@ ${QtLocation_GEN_DIR}/qplacesupplier_wrapper.cpp
${QtLocation_GEN_DIR}/qtlocation_module_wrapper.cpp
)
-if (Qt${QT_MAJOR_VERSION}Location_VERSION VERSION_EQUAL 5.11.0
- OR Qt${QT_MAJOR_VERSION}Location_VERSION VERSION_GREATER 5.11.0)
- list(APPEND QtLocation_SRC
- ${QtLocation_GEN_DIR}/qgeoserviceproviderfactoryv2_wrapper.cpp)
-endif()
set(QtLocation_include_dirs ${QtLocation_SOURCE_DIR}
${QtLocation_BINARY_DIR}