aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2024-03-25 13:28:43 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2024-04-04 13:44:07 +0200
commit5af78c7c420afebee05535130b059aa2809258b2 (patch)
tree6d1db4fd4f98df186cb97dfcd72f75a6374ac3fb /sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt
parentf89113e21645b5076d47b656140f0ceecf35fa09 (diff)
Build system: Clean Qt libraries linked by the modules
Only the bound Qt library needs to be linked, it will bring its dependencies. Add explanatory comment for the exceptions (QtTest, QtSql). Pick-to: 6.7 Task-number: PYSIDE-2649 Change-Id: Ib84d37248578a76400d307bb5d050005110677c3 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io> Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt b/sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt
index bab2fa5b0..5afec6ee1 100644
--- a/sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtQuickWidgets/CMakeLists.txt
@@ -30,13 +30,6 @@ set(QtQuickWidgets_include_dirs ${QtQuickWidgets_SOURCE_DIR}
${QtQuickWidgets_GEN_DIR})
set(QtQuickWidgets_libraries pyside6
- ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}OpenGL_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Network_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Quick_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Qml_LIBRARIES}
${Qt${QT_MAJOR_VERSION}QuickWidgets_LIBRARIES})
set(QtQuickWidgets_deps QtGui QtOpenGL QtQml QtQuick QtWidgets QtNetwork)