aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-11-02 16:11:52 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-11-02 16:12:04 +0000
commit25180730194bec25f915f32ab846ea583fb1493f (patch)
tree9a73e0336ecf21e085d99d6a651c5547b9eb99f8 /sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt
parent6e3e7b9ca0548430aaa5e2555d6e02c64625fa3f (diff)
Rename PySide2 to PySide6
Adapt CMake files, build scripts, tests and examples. Task-number: PYSIDE-904 Change-Id: I845f7b006e9ad274fed5444ec4c1f9dbe176ff88 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt b/sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt
new file mode 100644
index 000000000..9b6b5eb0a
--- /dev/null
+++ b/sources/pyside6/PySide6/QtTextToSpeech/CMakeLists.txt
@@ -0,0 +1,30 @@
+project(QtTextToSpeech)
+
+set(QtTextToSpeech_SRC
+${QtTextToSpeech_GEN_DIR}/qtexttospeech_wrapper.cpp
+${QtTextToSpeech_GEN_DIR}/qtexttospeechengine_wrapper.cpp
+${QtTextToSpeech_GEN_DIR}/qvoice_wrapper.cpp
+# module is always needed
+${QtTextToSpeech_GEN_DIR}/qttexttospeech_module_wrapper.cpp
+)
+
+set(QtTextToSpeech_include_dirs ${QtTextToSpeech_SOURCE_DIR}
+ ${QtTextToSpeech_BINARY_DIR}
+ ${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}
+ ${Qt${QT_MAJOR_VERSION}TextToSpeech_INCLUDE_DIRS}
+ ${libpyside_SOURCE_DIR}
+ ${QtCore_GEN_DIR})
+
+set(QtTextToSpeech_libraries pyside6
+ ${Qt${QT_MAJOR_VERSION}Multimedia_LIBRARIES}
+ ${Qt${QT_MAJOR_VERSION}TextToSpeech_LIBRARIES}
+ ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES})
+
+set(QtTextToSpeech_deps QtCore QtMultimedia)
+
+create_pyside_module(NAME QtTextToSpeech
+ INCLUDE_DIRS QtTextToSpeech_include_dirs
+ LIBRARIES QtTextToSpeech_libraries
+ DEPS QtTextToSpeech_deps
+ TYPESYSTEM_PATH QtTextToSpeech_SOURCE_DIR
+ SOURCES QtTextToSpeech_SRC)