aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2021-02-05 17:33:14 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2021-02-05 19:28:45 +0100
commitcd9a1b0543f65b0d8a4c1fa8e498438d5b5d67c9 (patch)
tree945d1ea333dffe879cd5c4bc479b6b533cba240b /sources/pyside6/plugins/CMakeLists.txt
parentaf1c32a6580b9514319b9f1d53510b4532cea913 (diff)
PySide6: Move the static UiTools plugin into a subdirectory
Task-number: PYSIDE-1455 Change-Id: I5d919f6a1d98cd1c6109b33c7e83b1ce97f50218 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/pyside6/plugins/CMakeLists.txt')
-rw-r--r--sources/pyside6/plugins/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/sources/pyside6/plugins/CMakeLists.txt b/sources/pyside6/plugins/CMakeLists.txt
deleted file mode 100644
index c3cd416a5..000000000
--- a/sources/pyside6/plugins/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-project(plugins)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS UiPlugin)
-
-set(ui_plugin_src
- customwidgets.cpp
- customwidget.cpp
-)
-
-qt_wrap_cpp(MOC_FILES ${ui_plugin_moc})
-
-add_library(uiplugin STATIC ${ui_plugin_src} ${MOC_FILES})
-if(CMAKE_HOST_UNIX AND NOT CYGWIN)
- add_definitions(-fPIC)
-endif()
-add_definitions(-DQT_STATICPLUGIN)
-
-if(${QT_MAJOR_VERSION} GREATER_EQUAL 6)
- set_property(TARGET pyside6 PROPERTY CXX_STANDARD 17)
-else()
- set_property(TARGET pyside6 PROPERTY CXX_STANDARD 11)
-endif()
-
-target_link_libraries(uiplugin
- Qt::Core
- Qt::Gui
- Qt::UiPlugin
- Qt::Widgets
- Shiboken6::libshiboken)
-if (CMAKE_BUILD_TYPE STREQUAL "Debug")
- set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_DEBUG_POSTFIX})
-else()
- set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_RELEASE_POSTFIX})
-endif()