aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/tests/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorCristián Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-07-13 19:57:24 +0200
committerCristián Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-07-20 16:56:48 +0200
commitbace73605d2e0483c6f8990452e701efdf4d5675 (patch)
tree57b3512e59bbf24dc458b652d29863a38ffa0813 /sources/pyside6/tests/QtCore/CMakeLists.txt
parent2654740274986e897427caf667fed93601e01bbd (diff)
pathlib: fix empty constructors in conversion
In some classes, like QDir, there is a default value for constructors that accept a QString: QDir(const QString &path = QString()) However this case was not considered in Python land when nothing is passed. Considering other classes might have a similar situation, we fix this at the level of the conversion and not per Qt class. To reproduce this issue, a simple: from PySide6.QtCore import QDir a = QDir() will segfault. Added a simple test case, and instructions to make the parameter optional (pyi). Task-number: PYSIDE-1499 Change-Id: I42156b87ca0aa60466c743a8cc8b42ea5eeb3559 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/pyside6/tests/QtCore/CMakeLists.txt')
-rw-r--r--sources/pyside6/tests/QtCore/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/sources/pyside6/tests/QtCore/CMakeLists.txt b/sources/pyside6/tests/QtCore/CMakeLists.txt
index e9717d9d0..82585f89c 100644
--- a/sources/pyside6/tests/QtCore/CMakeLists.txt
+++ b/sources/pyside6/tests/QtCore/CMakeLists.txt
@@ -62,6 +62,7 @@ PYSIDE_TEST(qcoreapplication_test.py)
PYSIDE_TEST(qdatastream_test.py)
PYSIDE_TEST(qdatetime_test.py)
PYSIDE_TEST(qdate_test.py)
+PYSIDE_TEST(qdir_test.py)
PYSIDE_TEST(qeasingcurve_test.py)
PYSIDE_TEST(qenum_test.py)
PYSIDE_TEST(qevent_test.py)