aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/ApiExtractor/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2019-06-07 23:20:59 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2019-06-07 23:20:59 +0200
commit731bb66abcd50573a1dfd478ae0495421d0d7339 (patch)
treea82bee72783db8f9063d857205972e71b1df3994 /sources/shiboken2/ApiExtractor/CMakeLists.txt
parent768541fb2e81a426daeffc2f81dcca42ecc43919 (diff)
parentb9a857b0fdcad47db958df635a5af934a8e90d62 (diff)
Merge "Merge remote-tracking branch 'origin/5.13' into dev"
Diffstat (limited to 'sources/shiboken2/ApiExtractor/CMakeLists.txt')
-rw-r--r--sources/shiboken2/ApiExtractor/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/sources/shiboken2/ApiExtractor/CMakeLists.txt b/sources/shiboken2/ApiExtractor/CMakeLists.txt
index 760cc6985..c55dba973 100644
--- a/sources/shiboken2/ApiExtractor/CMakeLists.txt
+++ b/sources/shiboken2/ApiExtractor/CMakeLists.txt
@@ -63,6 +63,8 @@ if (NOT DISABLE_DOCSTRINGS)
endif()
endif()
+target_compile_definitions(apiextractor PRIVATE CMAKE_CXX_COMPILER="${CMAKE_CXX_COMPILER}")
+
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)
if (BUILD_TESTS)