aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/ApiExtractor/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-01-06 12:14:30 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-01-06 12:14:30 +0100
commite4aa9e13ac6e4d38c473fc32ea4ace3777df7a57 (patch)
treea9ae19b0437a9816f804ac0ba90d43e75bd6c43c /sources/shiboken2/ApiExtractor/CMakeLists.txt
parent3a9ae5af078203b164a15b9fc4e9a726b84c849e (diff)
parent6534335da7d386d27d14cdc8a0198702f9229555 (diff)
Merge remote-tracking branch 'origin/5.14' into 5.15
Diffstat (limited to 'sources/shiboken2/ApiExtractor/CMakeLists.txt')
-rw-r--r--sources/shiboken2/ApiExtractor/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/sources/shiboken2/ApiExtractor/CMakeLists.txt b/sources/shiboken2/ApiExtractor/CMakeLists.txt
index c2a4c208e..65150eb92 100644
--- a/sources/shiboken2/ApiExtractor/CMakeLists.txt
+++ b/sources/shiboken2/ApiExtractor/CMakeLists.txt
@@ -46,6 +46,9 @@ if(NOT Qt5XmlPatterns_FOUND AND NOT HAS_LIBXSLT)
"Documentation will not be built due to missing dependency (no Qt5XmlPatterns found).")
endif()
+# Export to parent scope so that generator/CMakeLists.txt gets it
+set(DISABLE_DOCSTRINGS ${DISABLE_DOCSTRINGS} PARENT_SCOPE)
+
add_library(apiextractor STATIC ${apiextractor_SRC})
target_include_directories(apiextractor PRIVATE ${CLANG_EXTRA_INCLUDES}
${CMAKE_CURRENT_SOURCE_DIR}