aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken6/ApiExtractor/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-06 23:00:32 +0200
committerCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-07 15:31:43 +0200
commit59345eeef93d5bbd1af55426e2edf1963dcfb90c (patch)
tree2ae429f0150aef6d8e999eca0303aa847b671497 /sources/shiboken6/ApiExtractor/CMakeLists.txt
parent985ee0b6e55bc116f287ff2a09265fd3ef629f37 (diff)
cmake: bump general Qt minimum version
The main cmake files for pyside/shiboken still have minimum versions pointing to version <6.0.0 which is not valid anymore. Pick-to: 6.0 Change-Id: Iffebec1e6782e627fc6b3a0c9e16bce7864e250f Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/shiboken6/ApiExtractor/CMakeLists.txt')
-rw-r--r--sources/shiboken6/ApiExtractor/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/sources/shiboken6/ApiExtractor/CMakeLists.txt b/sources/shiboken6/ApiExtractor/CMakeLists.txt
index 04c410608..48bc3abbc 100644
--- a/sources/shiboken6/ApiExtractor/CMakeLists.txt
+++ b/sources/shiboken6/ApiExtractor/CMakeLists.txt
@@ -42,7 +42,7 @@ parser/enumvalue.cpp
xmlutils.cpp
)
-find_package(Qt${QT_MAJOR_VERSION}Xml 5.12)
+find_package(Qt${QT_MAJOR_VERSION}Xml 6.0)
find_package(LibXml2 2.6.32)
find_package(LibXslt 1.1.19)
@@ -88,7 +88,7 @@ target_compile_definitions(apiextractor PRIVATE CMAKE_CXX_COMPILER="${CMAKE_CXX_
set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)
if (BUILD_TESTS)
- find_package(Qt${QT_MAJOR_VERSION}Test 5.12 REQUIRED)
+ find_package(Qt${QT_MAJOR_VERSION}Test 6.0 REQUIRED)
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/tests)
enable_testing()
add_subdirectory(tests)