aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken6/tests/libsmart/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2022-06-24 11:07:51 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2022-06-30 14:28:13 +0200
commitac5837009960d0d92a8f48a70f3aab1a7b38a156 (patch)
treed7ae22bcffd61b7fea43ef48204573236e2e26ef /sources/shiboken6/tests/libsmart/CMakeLists.txt
parentf357d75b30890e7df853199f72560a3f34a290f2 (diff)
Add initial support for std::unique_ptr pointer
Known limitations: - No rich comparison is generated - Value conversions caused by passing pointers to derived classes do not work. [ChangeLog][shiboken6] Support for std::unique_ptr pointer has been added. Task-number: PYSIDE-454 Change-Id: I5ddf3156bb383598f91bb97d169d1e134918a161 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/shiboken6/tests/libsmart/CMakeLists.txt')
-rw-r--r--sources/shiboken6/tests/libsmart/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/sources/shiboken6/tests/libsmart/CMakeLists.txt b/sources/shiboken6/tests/libsmart/CMakeLists.txt
index 52a85e2a1..1a3a989da 100644
--- a/sources/shiboken6/tests/libsmart/CMakeLists.txt
+++ b/sources/shiboken6/tests/libsmart/CMakeLists.txt
@@ -4,6 +4,7 @@ set(libsmart_SRC
smart.cpp
stdsharedptrtestbench.cpp
stdoptionaltestbench.cpp
+stduniqueptrtestbench.cpp
)
add_library(libsmart SHARED ${libsmart_SRC})