aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 17 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8a43604d..f61a4f256 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,22 +1,28 @@
-cmake_minimum_required(VERSION 3.1)
-cmake_policy(VERSION 3.1)
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.18)
+cmake_policy(VERSION 3.18)
set(CMAKE_BUILD_TYPE Release CACHE STRING "Build Type")
-project(pyside2_super_project)
+project(pyside6_super_project)
if (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
message(FATAL_ERROR "In-source builds are not allowed.")
endif()
-# Used to prevent overriding message function in both shiboken2 and pyside2.
-set(is_pyside2_superproject_build 1)
+# Used to prevent overriding message function in both shiboken6 and pyside6.
+set(is_pyside6_superproject_build 1)
+
+add_subdirectory(sources/shiboken6)
-add_subdirectory(sources/shiboken2)
+# Ensure Shiboken6 and Shiboken6Tools packags are found during super-build
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken6/data")
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken6/generator")
+add_subdirectory(sources/pyside6)
-# Semi-hack to include exported shiboken variables.
-list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken2/data")
-add_subdirectory(sources/pyside2)
+add_subdirectory(sources/pyside-tools)
-# Semi-hack to include exported pyside2 variables.
-list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/pyside2/libpyside")
+# Ensure PySide package is found during super-build
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/pyside6/libpyside")