aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b18250bf..65172b351 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,22 +3,22 @@ cmake_policy(VERSION 3.16)
set(CMAKE_BUILD_TYPE Release CACHE STRING "Build Type")
-project(pyside2_super_project)
+project(pyside6_super_project)
if (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
message(FATAL_ERROR "In-source builds are not allowed.")
endif()
-# Used to prevent overriding message function in both shiboken6 and pyside2.
-set(is_pyside2_superproject_build 1)
+# Used to prevent overriding message function in both shiboken6 and pyside6.
+set(is_pyside6_superproject_build 1)
add_subdirectory(sources/shiboken6)
# Semi-hack to include exported shiboken variables.
list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken6/data")
-add_subdirectory(sources/pyside2)
+add_subdirectory(sources/pyside6)
add_subdirectory(sources/pyside-tools)
-# Semi-hack to include exported pyside2 variables.
-list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/pyside2/libpyside")
+# Semi-hack to include exported pyside6 variables.
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/pyside6/libpyside")