summaryrefslogtreecommitdiffstats
path: root/data
diff options
context:
space:
mode:
Diffstat (limited to 'data')
-rw-r--r--data/ApiExtractorConfig.cmake.in14
-rw-r--r--data/ApiExtractorConfigVersion.cmake.in9
-rw-r--r--data/CMakeLists.txt11
-rw-r--r--data/apiextractor.pc.in11
4 files changed, 45 insertions, 0 deletions
diff --git a/data/ApiExtractorConfig.cmake.in b/data/ApiExtractorConfig.cmake.in
new file mode 100644
index 00000000..666defb6
--- /dev/null
+++ b/data/ApiExtractorConfig.cmake.in
@@ -0,0 +1,14 @@
+# - try to find APIEXTRACTOR
+# APIEXTRACTOR_INCLUDE_DIR - Directories to include to use APIEXTRACTOR
+# APIEXTRACTOR_LIBRARIES - Files to link against to use APIEXTRACTOR
+
+SET(APIEXTRACTOR_INCLUDE_DIR "@CMAKE_INSTALL_PREFIX@/include/apiextractor@apiextractor_SUFFIX@")
+if(MSVC)
+ SET(APIEXTRACTOR_LIBRARY "@LIB_INSTALL_DIR@/@CMAKE_SHARED_LIBRARY_PREFIX@apiextractor@apiextractor_SUFFIX@.lib")
+elseif(WIN32)
+ SET(APIEXTRACTOR_LIBRARY "@CMAKE_INSTALL_PREFIX@/bin/@CMAKE_SHARED_LIBRARY_PREFIX@apiextractor@apiextractor_SUFFIX@@CMAKE_SHARED_LIBRARY_SUFFIX@")
+else()
+ SET(APIEXTRACTOR_LIBRARY "@LIB_INSTALL_DIR@/@CMAKE_SHARED_LIBRARY_PREFIX@apiextractor@apiextractor_SUFFIX@@CMAKE_SHARED_LIBRARY_SUFFIX@")
+endif()
+
+SET(APIEXTRACTOR_DOCSTRINGS_DISABLED @DISABLE_DOCSTRINGS@)
diff --git a/data/ApiExtractorConfigVersion.cmake.in b/data/ApiExtractorConfigVersion.cmake.in
new file mode 100644
index 00000000..a9f7318f
--- /dev/null
+++ b/data/ApiExtractorConfigVersion.cmake.in
@@ -0,0 +1,9 @@
+set(PACKAGE_VERSION @apiextractor_VERSION@)
+if("${PACKAGE_FIND_VERSION_MAJOR}" EQUAL @apiextractor_MAJOR_VERSION@)
+ if("${PACKAGE_FIND_VERSION_MINOR}" EQUAL @apiextractor_MINOR_VERSION@)
+ set(PACKAGE_VERSION_COMPATIBLE 1)
+ if("${PACKAGE_FIND_VERSION_PATCH}" EQUAL @apiextractor_MICRO_VERSION@)
+ set(PACKAGE_VERSION_EXACT 1)
+ endif()
+ endif()
+endif()
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
new file mode 100644
index 00000000..66b2f967
--- /dev/null
+++ b/data/CMakeLists.txt
@@ -0,0 +1,11 @@
+# create pkg-config file
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/apiextractor.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/apiextractor${apiextractor_SUFFIX}.pc" @ONLY)
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ApiExtractorConfig.cmake.in" "${CMAKE_CURRENT_BINARY_DIR}/ApiExtractorConfig.cmake" @ONLY)
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ApiExtractorConfigVersion.cmake.in" "${CMAKE_CURRENT_BINARY_DIR}/ApiExtractorConfigVersion.cmake" @ONLY)
+
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/apiextractor${apiextractor_SUFFIX}.pc" DESTINATION "${LIB_INSTALL_DIR}/pkgconfig")
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ApiExtractorConfig.cmake"
+ DESTINATION "${LIB_INSTALL_DIR}/cmake/ApiExtractor-${apiextractor_VERSION}")
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ApiExtractorConfigVersion.cmake"
+ DESTINATION "${LIB_INSTALL_DIR}/cmake/ApiExtractor-${apiextractor_VERSION}")
diff --git a/data/apiextractor.pc.in b/data/apiextractor.pc.in
new file mode 100644
index 00000000..5b59fc63
--- /dev/null
+++ b/data/apiextractor.pc.in
@@ -0,0 +1,11 @@
+prefix=@CMAKE_INSTALL_PREFIX@
+exec_prefix=@CMAKE_INSTALL_PREFIX@/bin
+libdir=@CMAKE_INSTALL_PREFIX@/lib
+includedir=@CMAKE_INSTALL_PREFIX@/include
+
+Name: apiextractor
+Description: Qt4 Binding Generator library
+Requires: QtCore
+Version: @apiextractor_VERSION@
+Libs: -L${libdir} -lapiextractor@apiextractor_SUFFIX@
+Cflags: -I${includedir}/apiextractor@apiextractor_SUFFIX@