aboutsummaryrefslogtreecommitdiffstats
path: root/examples/widgetbinding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgetbinding/CMakeLists.txt')
-rw-r--r--examples/widgetbinding/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/examples/widgetbinding/CMakeLists.txt b/examples/widgetbinding/CMakeLists.txt
index 909208e3a..1c5eefa50 100644
--- a/examples/widgetbinding/CMakeLists.txt
+++ b/examples/widgetbinding/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
cmake_minimum_required(VERSION 3.18)
cmake_policy(VERSION 3.18)
@@ -20,8 +23,8 @@ find_package(Qt6 COMPONENTS Core Gui Widgets)
# ================================ General configuration ======================================
-# Set CPP standard to C++11 minimum.
-set(CMAKE_CXX_STANDARD 11)
+# Set CPP standard to C++17 minimum.
+set(CMAKE_CXX_STANDARD 17)
# The wiggly library for which we will create bindings. You can change the name to something
# relevant for your project.