aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside2/CMakeLists.txt')
-rw-r--r--sources/pyside2/CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/sources/pyside2/CMakeLists.txt b/sources/pyside2/CMakeLists.txt
index d89b0f890..7799c0c7a 100644
--- a/sources/pyside2/CMakeLists.txt
+++ b/sources/pyside2/CMakeLists.txt
@@ -354,9 +354,20 @@ if (BUILD_TESTS)
add_subdirectory(tests)
endif ()
+find_program(SPHINX_BUILD sphinx-build)
find_program(DOT_EXEC dot)
-if (QT_SRC_DIR AND DOT_EXEC)
+
+if (QT_SRC_DIR AND SPHINX_BUILD AND DOT_EXEC)
add_subdirectory(doc)
else ()
- message(STATUS "QT_SRC_DIR variable not set or graphviz not found, apidoc generation targets disabled.")
+ set(DOCS_TARGET_DISABLED_MESSAGE "apidoc generation targets disabled.")
+ if (NOT QT_SRC_DIR)
+ message(STATUS "QT_SRC_DIR variable not set, ${DOCS_TARGET_DISABLED_MESSAGE}")
+ elseif (NOT SPHINX_BUILD)
+ message(STATUS "sphinx-build command not found, ${DOCS_TARGET_DISABLED_MESSAGE}")
+ elseif (NOT DOT_EXEC)
+ message(STATUS "graphviz not found, ${DOCS_TARGET_DISABLED_MESSAGE}")
+ else()
+ message(STATUS "Unknown issue occurred, ${DOCS_TARGET_DISABLED_MESSAGE}")
+ endif()
endif()