aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtNfc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtNfc/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtNfc/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/sources/pyside6/PySide6/QtNfc/CMakeLists.txt b/sources/pyside6/PySide6/QtNfc/CMakeLists.txt
new file mode 100644
index 000000000..b94249a55
--- /dev/null
+++ b/sources/pyside6/PySide6/QtNfc/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+project(QtNfc)
+
+set(QtNfc_SRC
+ ${QtNfc_GEN_DIR}/qndeffilter_record_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndeffilter_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndefmessage_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndefnfciconrecord_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndefnfcsmartposterrecord_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndefrecord_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndefnfctextrecord_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qndefnfcurirecord_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qnearfieldmanager_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qnearfieldtarget_wrapper.cpp
+ ${QtNfc_GEN_DIR}/qnearfieldtarget_requestid_wrapper.cpp
+# module is always needed
+ ${QtNfc_GEN_DIR}/qtnfc_module_wrapper.cpp)
+
+set(QtNfc_include_dirs ${QtNfc_SOURCE_DIR}
+ ${QtNfc_BINARY_DIR}
+ ${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}
+ ${Qt${QT_MAJOR_VERSION}Nfc_INCLUDE_DIRS}
+ ${libpyside_SOURCE_DIR}
+ ${QtCore_GEN_DIR})
+
+set(QtNfc_libraries pyside6
+ ${Qt${QT_MAJOR_VERSION}Nfc_LIBRARIES})
+
+set(QtNfc_deps QtCore)
+
+create_pyside_module(NAME QtNfc
+ INCLUDE_DIRS QtNfc_include_dirs
+ LIBRARIES QtNfc_libraries
+ DEPS QtNfc_deps
+ TYPESYSTEM_PATH QtNfc_SOURCE_DIR
+ SOURCES QtNfc_SRC)