aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt b/sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt
index f2e072fb4..fb0db5f83 100644
--- a/sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtPrintSupport/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
project(QtPrintSupport)
set(QtPrintSupport_SRC
@@ -13,9 +16,6 @@ ${QtPrintSupport_GEN_DIR}/qprintpreviewwidget_wrapper.cpp
${QtPrintSupport_GEN_DIR}/qtprintsupport_module_wrapper.cpp
)
-configure_file("${QtPrintSupport_SOURCE_DIR}/typesystem_printsupport.xml.in"
- "${QtPrintSupport_BINARY_DIR}/typesystem_printsupport.xml" @ONLY)
-
set(QtPrintSupport_include_dirs ${QtPrintSupport_SOURCE_DIR}
${QtPrintSupport_BINARY_DIR}
${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}
@@ -25,14 +25,11 @@ set(QtPrintSupport_include_dirs ${QtPrintSupport_SOURCE_DIR}
${libpyside_SOURCE_DIR}
${QtCore_GEN_DIR}
${QtGui_GEN_DIR}
- ${QtWidgets_GEN_DIR}
- )
+ ${QtWidgets_GEN_DIR})
+
set(QtPrintSupport_libraries pyside6
- ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}PrintSupport_LIBRARIES}
- )
+ ${Qt${QT_MAJOR_VERSION}PrintSupport_LIBRARIES})
+
set(QtPrintSupport_deps QtWidgets)
create_pyside_module(NAME QtPrintSupport
INCLUDE_DIRS QtPrintSupport_include_dirs