aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtScxml/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtScxml/CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/sources/pyside6/PySide6/QtScxml/CMakeLists.txt b/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
index 8cb78c9ee..1b0eab0ce 100644
--- a/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
project(QtScxml)
set(QtScxml_OPTIONAL_SRC )
@@ -6,10 +9,14 @@ set(QtScxml_DROPPED_ENTRIES )
set(QtScxml_SRC
${QtScxml_GEN_DIR}/qscxmlcompiler_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlcompiler_loader_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmlcppdatamodel_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmldatamodel_foreachloopbody_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmldatamodel_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlevent_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmldynamicscxmlservicefactory_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlinvokableservice_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlinvokableservicefactory_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmlnulldatamodel_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlstaticscxmlservicefactory_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlstatemachine_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmltabledata_wrapper.cpp
@@ -24,16 +31,6 @@ ${QtScxml_GEN_DIR}/qscxmlexecutablecontent_parameterinfo_wrapper.cpp
${QtScxml_GEN_DIR}/qtscxml_module_wrapper.cpp
)
-if (Qt${QT_MAJOR_VERSION}Scxml_VERSION VERSION_EQUAL 5.12.0
- OR Qt${QT_MAJOR_VERSION}Scxml_VERSION VERSION_GREATER 5.12.0)
- list(APPEND QtScxml_SRC
- ${QtScxml_GEN_DIR}/qscxmldatamodel_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmldatamodel_foreachloopbody_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmlecmascriptdatamodel_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmlcppdatamodel_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmlnulldatamodel_wrapper.cpp)
-endif()
-
set(QtScxml_include_dirs ${QtScxml_SOURCE_DIR}
${QtScxml_BINARY_DIR}
${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}