aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtSql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtSql/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtSql/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/sources/pyside6/PySide6/QtSql/CMakeLists.txt b/sources/pyside6/PySide6/QtSql/CMakeLists.txt
index ec6285926..fedebe642 100644
--- a/sources/pyside6/PySide6/QtSql/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtSql/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
project(QtSql)
set(QtSql_SRC
@@ -32,13 +35,13 @@ set(QtSql_include_dirs ${QtSql_SOURCE_DIR}
${libpyside_SOURCE_DIR}
${QtCore_GEN_DIR}
${QtGui_GEN_DIR}
- ${QtWidgets_GEN_DIR}
- )
+ ${QtWidgets_GEN_DIR})
+
+# Link to QtWidgets to enable QSqlRelationalDelegate
set(QtSql_libraries pyside6
- ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES}
${Qt${QT_MAJOR_VERSION}Sql_LIBRARIES})
+
set(QtSql_deps QtWidgets)
create_pyside_module(NAME QtSql