aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtSvg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtSvg/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtSvg/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/sources/pyside6/PySide6/QtSvg/CMakeLists.txt b/sources/pyside6/PySide6/QtSvg/CMakeLists.txt
new file mode 100644
index 000000000..748c8355c
--- /dev/null
+++ b/sources/pyside6/PySide6/QtSvg/CMakeLists.txt
@@ -0,0 +1,31 @@
+project(QtSvg)
+
+set(QtSvg_SRC
+${QtSvg_GEN_DIR}/qsvggenerator_wrapper.cpp
+${QtSvg_GEN_DIR}/qsvgrenderer_wrapper.cpp
+# module is always needed
+${QtSvg_GEN_DIR}/qtsvg_module_wrapper.cpp
+)
+
+set(QtSvg_include_dirs ${QtSvg_SOURCE_DIR}
+ ${QtSvg_BINARY_DIR}
+ ${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}
+ ${Qt${QT_MAJOR_VERSION}Gui_INCLUDE_DIRS}
+ ${Qt${QT_MAJOR_VERSION}Svg_INCLUDE_DIRS}
+ ${libpyside_SOURCE_DIR}
+ ${QtCore_GEN_DIR}
+ ${QtGui_GEN_DIR}
+ )
+set(QtSvg_libraries pyside6
+ ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
+ ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
+ ${Qt${QT_MAJOR_VERSION}Svg_LIBRARIES}
+ )
+set(QtSvg_deps QtGui)
+
+create_pyside_module(NAME QtSvg
+ INCLUDE_DIRS QtSvg_include_dirs
+ LIBRARIES QtSvg_libraries
+ DEPS QtSvg_deps
+ TYPESYSTEM_PATH QtSvg_SOURCE_DIR
+ SOURCES QtSvg_SRC)