aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtTest/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtTest/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/sources/pyside6/PySide6/QtTest/CMakeLists.txt b/sources/pyside6/PySide6/QtTest/CMakeLists.txt
index 4b14fabbf..86bb2a731 100644
--- a/sources/pyside6/PySide6/QtTest/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtTest/CMakeLists.txt
@@ -1,8 +1,12 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
project(QtTest)
set(QtTest_SRC
${QtTest_GEN_DIR}/qtest_pysideqtoucheventsequence_wrapper.cpp
${QtTest_GEN_DIR}/qabstractitemmodeltester_wrapper.cpp
+${QtTest_GEN_DIR}/qsignalspy_wrapper.cpp
${QtTest_GEN_DIR}/qtest_wrapper.cpp
# module is always needed
${QtTest_GEN_DIR}/qttest_module_wrapper.cpp
@@ -23,14 +27,15 @@ set(QtTest_include_dirs ${QtTest_SOURCE_DIR}
${libpyside_SOURCE_DIR}
${QtCore_GEN_DIR}
${QtGui_GEN_DIR}
- ${QtWidgets_GEN_DIR}
- )
+ ${QtWidgets_GEN_DIR})
+
+# Link to QtGui/QtWidgets to enable gui/widget-specific inline functions
set(QtTest_libraries pyside6
${Qt${QT_MAJOR_VERSION}Test_LIBRARIES}
${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES}
${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- )
+ ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES})
+
set(QtTest_deps QtWidgets)
create_pyside_module(NAME QtTest