aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtUiTools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtUiTools/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtUiTools/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/sources/pyside6/PySide6/QtUiTools/CMakeLists.txt b/sources/pyside6/PySide6/QtUiTools/CMakeLists.txt
index df54114d3..e16d2d585 100644
--- a/sources/pyside6/PySide6/QtUiTools/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtUiTools/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
project(QtUiTools)
set(QtUiTools_SRC
@@ -22,15 +25,12 @@ set(QtUiTools_include_dirs ${QtUiTools_SOURCE_DIR}
${plugins_SOURCE_DIR}
${QtCore_GEN_DIR}
${QtGui_GEN_DIR}
- ${QtWidgets_GEN_DIR}
- )
+ ${QtWidgets_GEN_DIR})
+
set(QtUiTools_libraries pyside6
uiplugin
- ${Qt${QT_MAJOR_VERSION}UiTools_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES}
- )
+ ${Qt${QT_MAJOR_VERSION}UiTools_LIBRARIES})
+
set(QtUiTools_deps QtWidgets)
configure_file("${QtUiTools_SOURCE_DIR}/QtUiTools_global.pre.h.in"