aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtWebChannel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/PySide6/QtWebChannel/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtWebChannel/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/sources/pyside6/PySide6/QtWebChannel/CMakeLists.txt b/sources/pyside6/PySide6/QtWebChannel/CMakeLists.txt
new file mode 100644
index 000000000..4c06edd2f
--- /dev/null
+++ b/sources/pyside6/PySide6/QtWebChannel/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+project(QtWebChannel)
+
+set(QtWebChannel_SRC
+${QtWebChannel_GEN_DIR}/qwebchannel_wrapper.cpp
+${QtWebChannel_GEN_DIR}/qwebchannelabstracttransport_wrapper.cpp
+# module is always needed
+${QtWebChannel_GEN_DIR}/qtwebchannel_module_wrapper.cpp
+)
+
+set(QtWebChannel_include_dirs ${QtWebChannel_SOURCE_DIR}
+ ${QtWebChannel_BINARY_DIR}
+ ${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}
+ ${Qt${QT_MAJOR_VERSION}WebChannel_INCLUDE_DIRS}
+ ${libpyside_SOURCE_DIR}
+ ${QtCore_GEN_DIR})
+
+set(QtWebChannel_libraries pyside6
+ ${Qt${QT_MAJOR_VERSION}WebChannel_LIBRARIES})
+
+set(QtWebChannel_deps QtCore)
+
+create_pyside_module(NAME QtWebChannel
+ INCLUDE_DIRS QtWebChannel_include_dirs
+ LIBRARIES QtWebChannel_libraries
+ DEPS QtWebChannel_deps
+ TYPESYSTEM_PATH QtWebChannel_SOURCE_DIR
+ SOURCES QtWebChannel_SRC)