aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/libpysideqml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/libpysideqml/CMakeLists.txt')
-rw-r--r--sources/pyside6/libpysideqml/CMakeLists.txt38
1 files changed, 21 insertions, 17 deletions
diff --git a/sources/pyside6/libpysideqml/CMakeLists.txt b/sources/pyside6/libpysideqml/CMakeLists.txt
index f6b4e1277..1af8c02cf 100644
--- a/sources/pyside6/libpysideqml/CMakeLists.txt
+++ b/sources/pyside6/libpysideqml/CMakeLists.txt
@@ -1,5 +1,24 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
set(libpysideqml_libraries Qt::Core Qt::CorePrivate Qt::Qml Qt::QmlPrivate)
+set(libpysideqml_HEADERS # installed below
+ pysideqmlattached.h
+ pysideqmlattached_p.h
+ pysideqmlextended_p.h
+ pysideqmlforeign_p.h
+ pysideqml.h
+ pysideqmllistproperty_p.h
+ pysideqmlmacros.h
+ pysideqmlmetacallerror_p.h
+ pysideqmlnamedelement_p.h
+ pysideqmlregistertype.h
+ pysideqmlregistertype_p.h
+ pysideqmltypeinfo_p.h
+ pysideqmluncreatable.h
+)
+
set(libpysideqml_SRC
pysideqml.cpp
pysideqmlattached.cpp
@@ -11,6 +30,7 @@ set(libpysideqml_SRC
pysideqmlnamedelement.cpp
pysideqmluncreatable.cpp
pysideqmltypeinfo.cpp
+ ${libpysideqml_HEADERS}
)
# Hack for // https://github.com/python/cpython/issues/86286 causes issues
@@ -39,7 +59,7 @@ set_target_properties(pyside6qml PROPERTIES
target_compile_definitions(pyside6qml PRIVATE -DQT_LEAN_HEADERS=1)
-set_property(TARGET pyside6 PROPERTY CXX_STANDARD 17)
+set_property(TARGET pyside6qml PROPERTY CXX_STANDARD 17)
if(PYSIDE_QT_CONF_PREFIX)
set_property(SOURCE pysideqml.cpp
@@ -52,22 +72,6 @@ endif()
# install stuff
#
-set(libpysideqml_HEADERS
- pysideqmlattached.h
- pysideqmlattached_p.h
- pysideqmlextended_p.h
- pysideqmlforeign_p.h
- pysideqml.h
- pysideqmllistproperty_p.h
- pysideqmlmacros.h
- pysideqmlmetacallerror_p.h
- pysideqmlnamedelement_p.h
- pysideqmlregistertype.h
- pysideqmlregistertype_p.h
- pysideqmltypeinfo_p.h
- pysideqmluncreatable.h
-)
-
if (CMAKE_BUILD_TYPE STREQUAL "Debug")
set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_DEBUG_POSTFIX})
else()