aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/plugins/designer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/plugins/designer/CMakeLists.txt')
-rw-r--r--sources/pyside6/plugins/designer/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/sources/pyside6/plugins/designer/CMakeLists.txt b/sources/pyside6/plugins/designer/CMakeLists.txt
index 50074be51..717652314 100644
--- a/sources/pyside6/plugins/designer/CMakeLists.txt
+++ b/sources/pyside6/plugins/designer/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
project(PySidePlugin)
# Note: At runtime, the dependency to the shiboken library is resolved
@@ -7,18 +10,18 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS UiPlugin)
+find_package(Qt6 COMPONENTS Core Gui Widgets UiPlugin)
qt_add_plugin(PySidePlugin)
target_sources(PySidePlugin PRIVATE
- designercustomwidgets.cpp
+ designercustomwidgets.cpp designercustomwidgets.h
)
# See libshiboken/CMakeLists.txt
+
+target_compile_definitions(PySidePlugin PRIVATE -DQT_NO_KEYWORDS=1)
+
if(PYTHON_LIMITED_API)
target_compile_definitions(PySidePlugin PRIVATE "-DPy_LIMITED_API=0x03050000")
endif()
@@ -53,4 +56,4 @@ target_link_libraries(PySidePlugin PRIVATE
Qt::Widgets
${SHIBOKEN_PYTHON_LIBRARIES})
-install(TARGETS PySidePlugin LIBRARY DESTINATION "plugins/designer")
+install(TARGETS PySidePlugin LIBRARY DESTINATION "${QT6_INSTALL_PLUGINS}/designer")