aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/tests/CMakeLists.txt')
-rw-r--r--sources/pyside6/tests/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/sources/pyside6/tests/CMakeLists.txt b/sources/pyside6/tests/CMakeLists.txt
index ac8e87989..539e1aea8 100644
--- a/sources/pyside6/tests/CMakeLists.txt
+++ b/sources/pyside6/tests/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
if(PYSIDE_IS_CROSS_BUILD)
# SHIBOKEN_PYTHON_INTERPRETER will be empty when cross-building.
message(WARNING
@@ -14,7 +17,7 @@ endif()
# the path to the testbinding module
get_filename_component(BUILD_DIR "${CMAKE_BINARY_DIR}" DIRECTORY)
get_filename_component(BUILD_DIR "${CMAKE_BINARY_DIR}" DIRECTORY)
-set(QT_DIR "${_qt5Core_install_prefix}")
+set(QT_DIR "${QT6_INSTALL_PREFIX}")
macro(TEST_QT_MODULE var name)
if(NOT DISABLE_${name} AND ${var})
@@ -51,6 +54,10 @@ add_subdirectory(support)
add_subdirectory(tools/metaobjectdump)
add_subdirectory(tools/pyside6-deploy)
+if(UNIX AND NOT APPLE)
+ add_subdirectory(tools/pyside6-android-deploy)
+endif()
+
if (NOT DISABLE_QtQuick)
add_subdirectory(tools/pyside6-qml)
endif()