aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken2/doc/CMakeLists.txt')
-rw-r--r--sources/shiboken2/doc/CMakeLists.txt23
1 files changed, 0 insertions, 23 deletions
diff --git a/sources/shiboken2/doc/CMakeLists.txt b/sources/shiboken2/doc/CMakeLists.txt
deleted file mode 100644
index 5903e9dfc..000000000
--- a/sources/shiboken2/doc/CMakeLists.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-find_program(SPHINX sphinx-build DOC "Path to sphinx-build binary.")
-
-if (SPHINX)
- message("-- sphinx-build - found")
- configure_file(conf.py.in conf.py @ONLY)
- add_custom_target(doc ${SPHINX} -b html -c . ${CMAKE_CURRENT_SOURCE_DIR} html )
-else()
- message("-- sphinx-build - not found! doc target disabled")
- if (WIN32)
- # if jom is used and we have no sphinx, then jom will crash.
- # so for windows, we always create a doc target (until jom gets fixed...)
- add_custom_target(doc echo.
- COMMAND echo +++ This is a fake build, to make 'jom' happy.
- COMMAND echo +++ The documentation was _not_ built!
- COMMAND echo.
- )
- endif()
-endif()
-
-if (NOT WIN32)
- file(GLOB manpages "${CMAKE_CURRENT_SOURCE_DIR}/*.1")
- install(FILES ${manpages} DESTINATION share/man/man1)
-endif()