aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/tests/otherbinding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken2/tests/otherbinding/CMakeLists.txt')
-rw-r--r--sources/shiboken2/tests/otherbinding/CMakeLists.txt43
1 files changed, 0 insertions, 43 deletions
diff --git a/sources/shiboken2/tests/otherbinding/CMakeLists.txt b/sources/shiboken2/tests/otherbinding/CMakeLists.txt
deleted file mode 100644
index bc5c4bdad..000000000
--- a/sources/shiboken2/tests/otherbinding/CMakeLists.txt
+++ /dev/null
@@ -1,43 +0,0 @@
-project(other)
-
-set(other_TYPESYSTEM
-${CMAKE_CURRENT_SOURCE_DIR}/typesystem_other.xml
-)
-
-set(other_SRC
-${CMAKE_CURRENT_BINARY_DIR}/other/extendsnoimplicitconversion_wrapper.cpp
-${CMAKE_CURRENT_BINARY_DIR}/other/number_wrapper.cpp
-${CMAKE_CURRENT_BINARY_DIR}/other/otherderived_wrapper.cpp
-${CMAKE_CURRENT_BINARY_DIR}/other/othermultiplederived_wrapper.cpp
-${CMAKE_CURRENT_BINARY_DIR}/other/otherobjecttype_wrapper.cpp
-${CMAKE_CURRENT_BINARY_DIR}/other/other_module_wrapper.cpp
-)
-
-
-configure_file("${CMAKE_CURRENT_SOURCE_DIR}/other-binding.txt.in"
- "${CMAKE_CURRENT_BINARY_DIR}/other-binding.txt" @ONLY)
-
-add_custom_command(
-OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/mjb_rejected_classes.log"
-BYPRODUCTS ${other_SRC}
-COMMAND shiboken2 --project-file=${CMAKE_CURRENT_BINARY_DIR}/other-binding.txt ${GENERATOR_EXTRA_FLAGS}
-DEPENDS ${other_TYPESYSTEM} ${CMAKE_CURRENT_SOURCE_DIR}/global.h shiboken2
-WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-COMMENT "Running generator for 'other' test binding..."
-)
-
-add_library(other MODULE ${other_SRC})
-target_include_directories(other PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}
- ${sample_BINARY_DIR}/sample)
-target_link_libraries(other PUBLIC libother libsample libshiboken)
-set_property(TARGET other PROPERTY PREFIX "")
-set_property(TARGET other PROPERTY OUTPUT_NAME "other${PYTHON_EXTENSION_SUFFIX}")
-
-if(WIN32)
- set_property(TARGET other PROPERTY SUFFIX ".pyd")
-endif()
-
-
-add_dependencies(other sample)
-create_generator_target(other)
-