aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken6/tests/dumpcodemodel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken6/tests/dumpcodemodel/CMakeLists.txt')
-rw-r--r--sources/shiboken6/tests/dumpcodemodel/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/sources/shiboken6/tests/dumpcodemodel/CMakeLists.txt b/sources/shiboken6/tests/dumpcodemodel/CMakeLists.txt
new file mode 100644
index 000000000..e7dbef961
--- /dev/null
+++ b/sources/shiboken6/tests/dumpcodemodel/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+add_executable(dumpcodemodel main.cpp)
+
+target_include_directories(dumpcodemodel
+ PRIVATE
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../ApiExtractor
+)
+
+target_link_libraries(dumpcodemodel
+ PRIVATE
+ apiextractor
+ Qt::Core
+)