aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken6/tests/libother/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken6/tests/libother/CMakeLists.txt')
-rw-r--r--sources/shiboken6/tests/libother/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/sources/shiboken6/tests/libother/CMakeLists.txt b/sources/shiboken6/tests/libother/CMakeLists.txt
new file mode 100644
index 000000000..0379d740b
--- /dev/null
+++ b/sources/shiboken6/tests/libother/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+project(libother)
+
+set(libother_SRC
+extendsnoimplicitconversion.h
+libothermacros.h
+number.cpp number.h
+otherderived.cpp otherderived.h
+othermultiplederived.cpp othermultiplederived.h
+otherobjecttype.cpp otherobjecttype.h
+othertypesystypedef.cpp othertypesystypedef.h
+smartptrtester.cpp smartptrtester.h
+)
+
+add_library(libother SHARED ${libother_SRC})
+target_include_directories(libother PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
+target_compile_definitions(libother PRIVATE LIBOTHER_BUILD)
+target_link_libraries(libother PUBLIC libsample libsmart)
+set_property(TARGET libother PROPERTY PREFIX "")
+
+