aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Lacko <backup.rlacko@gmail.com>2013-08-01 18:53:27 +0200
committerRoman Lacko <backup.rlacko@gmail.com>2013-08-01 18:53:27 +0200
commit8783dfcbb58f7d8c60aa0624fe6d99a36ba9a393 (patch)
treec59c1192f3420326a5ce5c5a57eb902bc196426f /CMakeLists.txt
parent92062bcf842814328a9f4a89f10c115bfcace0b3 (diff)
Fixed site-packages resolution on Linux with both python 3.x and 2.x installed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d609d7..4e9eb5d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,7 @@
-
cmake_minimum_required(VERSION 2.6)
project(pyside-tools)
-find_package(PythonInterp REQUIRED)
+find_package(Shiboken 1.1.1 REQUIRED)
find_package(Qt4 4.5.0 REQUIRED)
find_package(PySide 1.0.6 REQUIRED)
@@ -18,7 +17,7 @@ option(BUILD_TESTS "Build tests." TRUE)
# UIC stuff
if (NOT SITE_PACKAGE)
execute_process(
- COMMAND ${PYTHON_EXECUTABLE} -c "from __future__ import print_function; \\
+ COMMAND ${SHIBOKEN_PYTHON_INTERPRETER} -c "from __future__ import print_function; \\
from distutils import sysconfig; \\
print(sysconfig.get_python_lib(1,0,prefix='${CMAKE_INSTALL_PREFIX}'))"
OUTPUT_VARIABLE SITE_PACKAGE
@@ -74,3 +73,4 @@ if (BUILD_TESTS)
enable_testing()
add_subdirectory(tests)
endif ()
+