aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2011-01-13 15:43:00 -0200
committerHugo Parente Lima <hugo.pl@gmail.com>2011-01-13 17:07:22 -0200
commitcea64df8aedfdb2c8d8fe60bc329e6d15080e14d (patch)
treefe4f1cebbadc37e6d04d30bcd041b505c004b1c7 /CMakeLists.txt
parent71c2737423e16f854e0c9736b1518ee49d2c9c39 (diff)
Merge latest changes from PyQt4 uic into PySide uic avoiding the loadUi function due to license issues.
Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed6236a..dc748ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ set(pyside_tools_MINOR_VERSION "2")
set(pyside_tools_MICRO_VERSION "5")
set(pyside_tools_VERSION "${pyside_tools_MAJOR_VERSION}.${pyside_tools_MINOR_VERSION}.${pyside_tools_MICRO_VERSION}")
-configure_file(pyside-uic.in pyside-uic @ONLY)
+configure_file("pysideuic/__init__.py.in" "__init__.py" @ONLY)
# UIC stuff
execute_process(
@@ -25,16 +25,18 @@ if (NOT SITE_PACKAGE)
message(FATAL_ERROR "Could not detect Python module installation directory.")
endif()
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pyside-uic
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/pyside-uic
DESTINATION bin
PERMISSIONS
OWNER_EXECUTE OWNER_WRITE OWNER_READ
GROUP_EXECUTE GROUP_READ
WORLD_EXECUTE WORLD_READ)
-
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/__init__.py"
+ DESTINATION "${SITE_PACKAGE}/pysideuic")
install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/pysideuic
- DESTINATION ${SITE_PACKAGE})
+ DESTINATION ${SITE_PACKAGE}
+ PATTERN "*.in" EXCLUDE)
# Man pages for pyside-uic
if (NOT win32)